WordPress 3.3 – No Internet Explorer 6 Support

Andrew Ozz stated in the article called The big CSS overhaul in 3.3 that it is taken into consideration that WordPress 3.3 admin panel will have no support for IE6 anymore. Andrew's statement:

Following the discussion at the UI irc meetup yesterday, I think it’s time to start planning for the CSS overhaul for 3.3. I’ve been dreaming to do that since before 2.7 came out and finally we seem to have the opportunity to accomplish it (no more IE6!).

Indeed without all the hacks for IE6 the CSS coding would be much shorter and the browsers should render much faster, beside, from my point of view any blog author should have all major browsers installed at least to make sure that there's a check for how your WordPress theme looks like in every browser. Having all major browsers installed and using IE6 for everyday work and WordPress admin panel would be nonsense in this case.

But how about IE6 support for WordPress themes?

When I look at the statistics I am so happy to see that from long time ago now the number one and two position in my visitors browser choice in Firefox and Chrome, and Internet Explorer is somewhere from 6% to 9% for all versions as the visitors choice. Out of this percentage IE6 makes less then 1% (and had 1 visitor last month using IE5.5). So this is not bad, but should we ignore this users when it comes to WordPress themes? My self, when releasing a WordPress theme always try to make sure that will look well in all IE versions, including IE6. I've noticed that when releasing a theme on ThemeForest.net IE6 support is not required (or at least mandatory) anymore.

An example of a theme viewed in Firefox and IE6 and the TwentyTen Church theme in the same conditions:
firefox-vs-ie6

Is this the right thing to do? Should theme developers ignore IE6 users as well? Worth the effort of making a theme working well in IE6 browser? Would like to hear your opinion...

Comments

  1. says

    I think if a theme is not made to work with IE6 at least a conditional warning should be displayed to the visitor that it's using an outdated browser and should be changed or updated at least for security reasons.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">